First Impressions / Mini Review of F-07C

It came!

I purchased the device last Wednesday, it shipped Friday, got to me this Monday.

Initial Impressions. I LOVE this little thing. I did not realize how small it really was. I was shocked and amazed its nearly the same size as my iPhone length and width wise. Depth wise its about 2 iPhones stacked on top of each other.

This isn’t a device that works out of the box. It could take the average user 1-2 weeks of tweaking / trial and error to get the device working to a point the user can be happy with. Granted while the device has its faults, it’s one of the most capable UMPC’s I have tried to date.

The last UMPC I owned was the Fujitsu u820. I have to say, this device, while much smaller and lighter runs circles around it. In every shape in form I believe. I was a bit skeptical going in to be honest because lets face it, the driver support for the GMA500 was a disaster and it severely crippled the u820. I read some good things about the GMA600 though and so I ended up pulling the trigger.

Initially when getting the device I was astounded at how fast it actually was at 600Mhz (Mind you I deleted like half the crap they put on this thing). When I boosted it to 1.2Ghz the thing flew! I just can’t get over how such a tiny device has so much power. It does not (to me at least) get that hot when unlocked. If you have it hooked in to the charger and unlocked, it does get quite hot. Once the phone threw me out of Win 7 into MOAP(s) and said ‘Mode Switched to prevent overheating’ LOL! I think thats pretty cool they took that precaution. I am not worried about heat though. After some reading about the amount of heat Atom CPUs can tolerate I disconnected that annoying fan they put in the u820, which I am sure is the same one they put in the cradle for this thing.  My u820 has been fan-less since early 2009 and have had no issues :)

Battery life wise. I kept the FJ023 service on because if you disable it, the touch console ceases to work. I use the console to easily start applications, turn on Wifi / SD among other things. With this I get about 1 h 30 mins or so before it throws me into MOAP(s). When in MOAP(s) many features will not work (like the camera) due to low battery life (it conserves it for you). You can still text and call though which is very nice. I did this at night and went to sleep. Woke up and my the phone was still chugging (after about 7 hours of sleep mode). I had some missed calls and txts. I think thats pretty neat that it has somewhat of a reserve battery stash for strict phone business. I really want to hook this puppy up to my 16000mAh battery (seen in picture above) but as you can see I can’t get the connector port to act right with me! I am sure I could have a lot of juice to pump from there. I also ordered an Eneloop Booster Stick from Japan for a more pocketable battery reserve.

Pluses:

  • GMA600 fully supports hardware acceleration in almost everything! DXVA and Direct3D included (Sadly flash does not however, but there is a way around this) I cannot stress enough how amazing this thing is. It completely blows me away at everything I through at it (mind you after some tweaking and settings adjustments) Many of the games that failed miserably on my u820 are not only playable, but work 100% flawlessly!
  • The keyboard / trackball combo is very very nice to use once you get used to it (I did almost instantly, much more than I can say for the u820′s nub – that thing was horrible)
  • This is much better IMO than the nub used for the u820, I can easily navigate and play lots of games almost effortlessly with it.
  • Keyboard is backlit! (Since I use the device mainly at night in bed for browsing, gaming and viewing
  • Resume / Hibernation / Switching is very very fast. Switching when clocked at 1.2GHz is almost instantaneous. Resuming takes all but about 15 seconds.
  • Fast startup! When you disable many of the annoying included Fujitsu thingies, startups can be very very quick from 35-45 seconds (I haven’t timed any of these they are all estimates)
  • Many other things I can’t think of to name!

Hurdles:

  • The first aggravating thing I stumbled over is the charger. You CAN NOT I repeat, CAN NOT charge this device using anything other than the supplied AC to USB adapter through the micro-usb port. While charging the device can be done through the proprietary port, it’s still very frustrating. Every time you try to connect a device you get this:

  • I’m going to have to rig up something better than this first attempt at getting USB to work:
  • Lol. It looked much better to begin with until I got frustrated and chopped / cut everything to hell. I could not figure out the proper pinouts for the life of me. 2-7 should be 5V, 10, 11 should be D+ D- for USB and one of the #’s stated should be ground. None of these worked for me. I did manage to get the display to try to output HDMI video though. So I know at least its reading the pins / wires, but the combo’s I tried lead to no avail.
  • Wi-fi automatically switches off whenever you switch to MOAP(s). This is very very frustrating. I have disabled everything in the Atheros properties panel to prevent it from sleeping / going into power saving mode. I changed my power plan options to reflect ‘maximize performance’ and still it does it. I can’t tell what exactly is happening when the switch occurs. It does not hibernate. Maybe it sleeps? If so disabling these options would have solved the issue. I am not sure. I am going to write a script to launch the wifi on whenever waking from sleep mode and see if that does anything.
  • Sometimes the network sharing of drives from my other computer ceases to show up on the device. When trying to make the connection from other computers, it times out. Restarting the Wi-Fi does not help. It will randomly appear / work sometime later. Not sure what the cause of this is.
  • No USB port or helpful port to go into USB. As stated before it requires a lot of effort and time to make your own or a lot of money (around $200+ shipped) to get a cradle.
  • There seems to be interference with the unit’s speaker whenever using 3G modem / Wi-Fi. Its subtle usually, only heard when you directly place your ear up the speaker, but sometimes it gets very loud when a lot of data is being transferred.
  • I cannot for the life of me figure out how to change the screen brightness. In Power settings nothing happens when changing the slider. I read in the manual you have to go to Control Panel -> Hardware and Sound but this does not exist in the control panel! It also states the second bulb thing (that appears to be a light) is a light sensor that changes the brightness automatically. Whatever service is managing this is probably taking over the brightness control in the control panel. I have not figured out what it is to stop it from happening. The brightness adjustment also can get on your nerves after a while and drains battery life.
  • I can’t seem to get the 3G Modem to work in Win 7, but I know I am close. I have gotten it to receive / send packets of data but the ones received aren’t proper chunks and the network access reamins null. Ishman pointed out he could not get the AT&T connection manager to work for him. This is true. The [B]newest[/B] version of the manager indeed does not see the F-07C FOMA card. But, if you use the 6.9.115 version found [URL="http://www.wireless.att.com/businesscenter/en_US/download/Setup-ACM-6.9.115.exe"]here[/URL] it sees the card, can see your telephone number and communicate with the card (It’s also the last version of the manager to allow you to change the APN). Here is the thing. I [I]know[/I] I can get it working hopefully if I can switch the connection method from PPP to IP. There is an option to do this in the manager. Here is the conundrum though. When starting the manager it warns you saying “A non AT&T based SIM modem blah blah blah was detected, do you wish to set up a new profile for this device?”

  • When you click yes it allows you to set up the card, BUT it does NOT allow you to change to IP from PPP. After you set this up, it disappears never to be seen again. But it does see the device.

  • You can’t edit the profiles within the program. You can only set up and edit new profiles that are not for the device you just set up. It is very frustrating knowing this is all I need to do and can’t get to it. I’m going to go digging for the conf files and try editing them manually. Also another factor that comes into play here is how the phone is set to in its ‘Overseas Settings’. You can go from ‘Auto’ to ’3G’ to ‘GPRS/GSM’. All these modes play a role in how the modem behaves in Win 7. If you switch it to GPRS/GSM, the modem will not function at all in Win 7. So it is between 3G / Auto to figure out some combination of getting the modem to work.
  • I will note that I DID get the modem to get network access using the DoCoMo manager initially after messing around with some settings when I first pulled the phone out of the box and began playing with it. However I could not get the internet to pop up and then to make matters worse I got a phone call. After going back to Win 7, I could not remember the settings I had to get to that point. Trying to get back, the DoCoMo manager would successfully connect with IP but display a yellow ‘yielding’ triangle in the tray… a.k.a no network access :(
  • It’s a Japanese Keitai this means little to anything will work on the MOAP(s) side of things.  No 3G, no I-mode, no GPS, no Wi-Fi, no Email no pretty much anything. All these are features bound to DoCoMo’s service and UIM cards. Trying to use these features will result in a ‘Cannot Use this feature with this UIM’. You can however do: Calling / txting (in Japan, they don’t SMS, they use e-mail for pretty much everything so when you do receive a SMS it comes into your mail inbox and has a format close to like an email – Nothing fancy here), use the pedometer / workout manager, alarm clock, timer calculator, notes etc. All the usual phone features that don’t require some sort of service or internet. Sadly nothing will change this, not even a Hyper-Sim. You can always buy a DoCoMo USA Plan and put the phone into overseas mode. I am sure all the features will work then. I am still trying to figure out exactly how the device works, hopefully try and manage a rom dump, though that won’t come until I get settled in Win 7.

Skype: It works perfectly. Smooth video with your contact the the front facing camera delivers a lag free visual. The only issue I ran into with choppiness was when my friend tried to stream me his 1920×1200 resolution desktop running a fullscreen Youtube video :P , then things did not go so smoothly. Can’t fault the device for that one though haha. If you want when I get a chance I can try to set up another session and make a video for you of it in action.

Oh and for the videos posted about the device having poor video power, its complete crap. The device ships with a slew of outdated software / drivers which I am sure many people are failing to change and on top of that he’s using Internet Explorer!!!!! Flash ships on this machine at version 10.1, we are now on 10.3, so that is one thing to fix, and also get Chrome! Though flash is at fault here too, it provides no native hardware acceleration with the GMA600. To watch HD Youtube you will have to use CyberLink DVD 11′s Youtube tab (works just like the iPhone / iPad version of Youtube, has a touch interface too!)

Here is a video of my F-07C playing 720P .mkv’s of some movies flawlessly using GMA600 HW Accel:

Edit: After some traffic to it, Square Enix shut it down! Here is a replacement

I will be making more videos of various things. One being a games test. I managed to get this thing to run Unreal Tournament @ 1024×600, Maxed out settings @ full FPS. Too bad I have no way of hooking up a mouse and keyboard… yet. LOL

Overall, if you have the patience, perseverance and determination, you can make the device work / fit most of your needs. At least I think :p

8 thoughts on “First Impressions / Mini Review of F-07C

  1. Very thorough first impression, thanks for sharing!

    I have a question after reading your article though that is totally unrelated to the F-07C. After removing the fan from the U820 how did you deal with the post error about the missing fan?

    Thanks! Also, you made me want a F-07C…..

    damn you….

    • Thanks!

      I don’t have my u820 with me currently (it’s packed away as I just moved) but there is an option in the bios to turn off ‘System Sounds or Alerts?’ I don’t remember off the top of my head but you should find it. I think it is one of the only sound options available. Its the only one offered that you have an option to turn off. If you do, any system beeping noises will be turned off (it won’t affect system sounds)

      If you still can’t find it later when I have a chance to get to the device I can give you the exact place its at.

  2. whats all the stuff you deleted as far as programs and services and also what are all the tweaks you did to make the os run faster, also like a said before what software would you reccomend everyone to have for the device

    thanks in advance
    -josh

    • I didn’t delete anything from the device. Trying to rid the bloat will do more harm then good. The only things I deleted were the shortcuts and the Norton Antivirus. I’d recommend keeping everything else, it’s crucial for the device to work properly with the phone side.

      Best programs? Hmmm dunno.. I’d say over-clocking CPUID. Also check out Omnimo. It makes your phone look and act like Windows Phone 7 with the Metro UI ;)

      • i have noticed that it has 2 card readers on the back so i was thining if i put a 32gb micro SD level 10 and a 32gb of the other card type, i will have 64gb of space, what i wanted to know was what cards are the best to place in it and also whats the max gb of card it can take, further more, i cant for the life of me figure out how on the windows 7 side of the phone take files and put them into the phone side, can it be done without the cards and if not how do you do it with the cards, i would like to be able to play music and vid and upload pics on facebook and such and such but so far all i have figured out is how to take the pics i took on the phone and load them to the microSD which then i dont know how to open from the Win7 side, n00bish? sad? yes very much, i reallllyyy dont want to buy that cradle, this besides the japaneese problem which your post solved is my biggest hurdle… well this and the fact that i dont even know how to sign this up and turn it into a phone beacuse the people i talk to tell me “windows 7 cant ron on android” and laugh….. and i am thinking to myself…. ” walk away its not worth it even if i embarressed them they still wouldnt know and would like monkeys trying to work a typewriter” please help

  3. how do i play and view pdf, music, vid, on the phone side of the device? all the files are on the Win7 side and i have tried to put them on microSD and open on phone side but it says items not found, i have used this device for 3 months and have not been able to use it as mp3 player or vid player or pdf reader, please help

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>